Barrie Public Library - Enriching our Community

Search the catalogue for books, movies, articles, events & more.

 

OverDrive App for iOS - update required

Jan
16
2017

OverDrive App for iOS - update required

To install the latest version of the OverDrive app, you'll need iOS 8 or higher.

This version of the app requires new users to sign into the app, which authorizes you to download Adobe (DRM-protected) eBooks.